Gemini Connected - We have discovered an issue with the service release of Gemini Terrain version 20.0.2.502 – Incident details

Gemini Terrain experiencing degraded performance

We have discovered an issue with the service release of Gemini Terrain version 20.0.2.502

Identified
Degraded performance
Started 13 days ago

Affected

Gemini Terrain

Degraded performance from 10:39 AM to 12:00 AM

Updates
  • Update
    Update

    We have discovered an issue with the service release of Gemini Terrain due to unexpected versioning in a third-party library. As a result, the library in question was not updated, which led to errors in release 20.0.2.502.

    To avoid any issues, we ask you to roll back to version 20.0.1.

    Here’s how to proceed:

    1. Uninstall Gemini version 20.

    2. Delete the following folders:

      • C:\Program Files\Gemini\Ter20

      • C:\Users\xxxx\AppData\Local\Gemini\Ter20

    3. Install Gemini version 20.0.1

    You can download version 20.0.1 from our website.

  • Identified
    Identified

    We have discovered an issue with the service release of Gemini Terrain due to unexpected versioning in a third-party library. As a result, the library in question was not updated, which led to errors in release 20.0.2.502.

    We ask everyone who has installed this version to run a “repair” on the installation, which will resolve the issue.