All systems operational

New incident

Resolved
Degraded performance
Started 10 months ago Lasted 33 minutes

Affected

Gemini Connected Web
Gemini Terrain
Gemini ProAdm
Gemini Connected APIs
Updates
  • Resolved
    Resolved

    We have fixed the issue and everything seems to be working as it should

  • Investigating
    Investigating

    We have detected a problem and are working to find out what caused the problem